Monday, March 28, 2011

UDP Forwarding Support for IP Redundancy Virtual Router Group

User Datagram Protocol (UDP) forwarding is a Cisco IOS feature used to forward broadcast and multicast packets received for a specific IP address. Virtual Router Group (VRG) support is currently implemented with the Hot Standby Routing Protocol (HSRP), which groups multiple routers as a logical router.

The UDP Forwarding Support for IP Redundancy Virtual Router Group feature enables the forwarding of UDP-based broadcast and multicast packets to be VRG aware – forwarding is only done by the active router in the VRG, instead of all routers within the VRG, which can cause some DHCP servers to operate incorrectly.

VRG awareness is achieved with IP Redundancy Service (IRS), which provides addition, deletion, state change notifications / updates, and state querying of a VRG. State change notification is used to avoid the performance impact of the periodic state querying of the VRG. The UDP forwarding process caches the VRG state for each defined helper address. When the UDP forwarding process executes, it checks the current state of the VRG associated with the helper address, followed by the forwarding action performed by the active router in the VRG.


Below shows the HSRP states on RT1 and RT2:
RT1#sh standby
FastEthernet1/0 - Group 1
  State is Active
    6 state changes, last state change 00:24:45
  Virtual IP address is 10.1.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
  Hello time 3 sec, hold time 10 sec
Next hello sent in 0.164 secs
  Preemption enabled
  Active router is local
  Standby router is 10.1.1.3, priority 100 (expires in 8.508 sec)
  Priority 110 (configured 110)
  IP redundancy name is "hsrp-Fa1/0-1" (default)
RT1#
======================================================================
RT2#sh standby
FastEthernet1/0 - Group 1
  State is Standby
    7 state changes, last state change 00:24:56
  Virtual IP address is 10.1.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.280 secs
  Preemption disabled
  Active router is 10.1.1.2, priority 110 (expires in 6.836 sec)
  Standby router is local
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Fa1/0-1" (default)
RT2#

The output of the debug ip packet command on RT1 and RT2 shows that the DHCP (UDP) forwarding is performed by all routers within the VRG before this feature is enabled:
RT1#debug ip packet 101
IP packet debugging is on for access list 101
RT1#
00:25:16: IP: s=0.0.0.0 (FastEthernet1/0), d=255.255.255.255, len 604, rcvd 2
00:25:16: IP: tableid=0, s=10.1.1.2 (local), d=10.2.2.10  (FastEthernet2/0), routed via FIB
00:25:16: IP: s=10.1.1.2 (local), d=10.2.2.10 (FastEthernet2/0), len 604, sending
--------------------------------------------------
RT2#debug ip packet 101
IP packet debugging is on for access list 101
RT2#
00:25:16: IP: s=0.0.0.0 (FastEthernet1/0), d=255.255.255.255, len 604, rcvd 2
00:25:16: IP: tableid=0, s=10.1.1.3 (local), d=10.2.2.10 (FastEthernet2/0), routed via FIB
00:25:16: IP: s=10.1.1.3 (local), d=10.2.2.10 (FastEthernet2/0), len 604, sending
Remarks:
access-list 101 remark *** Filter HSRP packets in debug ip packet ***
access-list 101 deny ip any 224.0.0.0 0.0.0.255
access-list 101 permit ip any any

Below shows the UDP Forwarding Support for IP Redundancy Virtual Router Group configuration on RT1 and RT2:
RT1:
interface FastEthernet1/0
 ip address 10.1.1.2 255.255.255.0
 ip helper-address 10.2.2.2 redundancy hsrp-Fa1/0-1
 standby 1 ip 10.1.1.1
 standby 1 priority 110
 standby 1 preempt
!
--------------------------------------------------
RT2:
interface FastEthernet1/0
 ip address 10.1.1.3 255.255.255.0
 ip helper-address 10.2.2.2 redundancy hsrp-Fa1/0-1
 standby 1 ip 10.1.1.1
!

The ip helper-address {ip-addr} redundancy {vrg-name} interface subcommand enables the UDP Forwarding for IP Redundancy Virtual Router Group feature for a particular interface.
Note: This feature is available only on platforms that support VRGs.

After this feature is enabled on RT1 and RT2, the UDP forwarding is only done by RT1 at a time, the active router in the VRG.

The debug ip packet messages below shows that RT2 forwards the UDP DHCP requests to 10.2.2.10 (DHCP server) when it becomes the active router in the VRG when RT1 fails.
RT2#sh standby
FastEthernet1/0 - Group 1
  State is Active
    8 state changes, last state change 00:01:39
  Virtual IP address is 10.1.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.336 secs
  Preemption disabled
  Active router is local
  Standby router is unknown
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Fa1/0-1" (default)
RT2#
00:32:46: IP: s=0.0.0.0 (FastEthernet1/0), d=255.255.255.255, len 604, rcvd 2
00:32:46: IP: tableid=0, s=10.1.1.3 (local), d=10.2.2.10 (FastEthernet2/0), routed via FIB
00:32:46: IP: s=10.1.1.3 (local), d=10.2.2.10 (FastEthernet2/0), len 604, sending
RT2#

24 comments:

  1. Interesting topic for a blog. I have been searching the Internet for fun and came upon your website. Fabulous post. Thanks a ton for sharing your knowledge! It is great to see that some people still put in an effort into managing their websites. I'll be sure to check back again real soon. https://bestcheapvpn.com/

    ReplyDelete
  2. If yours is a one time kind of delivery, this may not be cost effective for you. However, if you need to ship every other month, such a service provider can help you save. Таможенное оформление в россии и беларуси

    ReplyDelete
  3. I wanted to thank you for this great read!! I definitely enjoying every little bit of it I have you bookmarked to check out new stuff you post. TutuApp iOS 11

    ReplyDelete
  4. Thanks For sharing this Superb article.I use this Article to show my assignment in college.it is useful For me Great Work. AppEven Download

    ReplyDelete
  5. This comment has been removed by the author.

    ReplyDelete
  6. An fascinating discussion is value comment. I think that it is best to write extra on this matter, it won’t be a taboo topic however generally people are not enough to talk on such topics. To the next. Cheers wlan knacken

    ReplyDelete
  7. I know that I take a regular dosage of the slowest poison that drips on earth. It is administered in prescribed amounts over a period of twenty-four hours every day. Stress slowly infiltrates my pores and leaves its sticky and deadly residue within my veins.free ip stresser

    ReplyDelete
  8. I know that I take a regular dosage of the slowest poison that drips on earth. It is administered in prescribed amounts over a period of twenty-four hours every day. Stress slowly infiltrates my pores and leaves its sticky and deadly residue within my veins
    access router

    ReplyDelete
  9. Among one of the finest pieces on the web, awakening in its specificity.
    192 168.0 1

    ReplyDelete
  10. I like your post. It is good to see you verbalize from the heart and clarity on this important subject can be easily observed... https://192-168-i-i.com

    ReplyDelete
  11. Incredible posting this is from you. I am really and truly thrilled to read this marvelous post. You've really impressed me today. I hope you'll continue to do so! En savoir plus

    ReplyDelete
  12. I'm really impressed about the info you provide in your articles. If you want to invest in suits and be stress-free, then you should shake hands with us. We are providing great clothing in the most reasonable price range that you wouldn’t find anywhere else. Put your trust in us as your supplier since we are the prominent custom stickers printing You can rely on us for the clothing problems we assure you we will never let our customers down.

    ReplyDelete
  13. Grandstream PBX System- Grandstream Distributor Cameroon VDS the Grandstream distributor in  Cameroon continues to bring innovative Grandstream Products to the IP communications / Telephony market with compelling values and features. Grandstream Networks is headquartered in Brookline, Massachusetts with offices in Yealink IP Phones

    ReplyDelete
  14. Great survey, I'm sure you're getting a great response. 192.168.49.1

    ReplyDelete
  15. Attractive information on your blog, thank you for taking the time and share with us.
    Die Cut Bookmarks

    ReplyDelete
  16. Wow, excellent post. I'd like to draft like this too - taking time and real hard work to make a great article. This post has encouraged me to write some posts that I am going to write soon
    Reflective Stickers

    ReplyDelete
  17. Hello, I want to subscribe for this web site to take most up-to-date updates, thus where can i do it please help out.
    Hologram Stickers

    ReplyDelete
  18. I'm really impressed about the info you provide in your articles. If you want to invest in suits and be stress-free, then you should shake hands with us. custom hair extension boxes

    ReplyDelete
  19. m going to read this. I’ll be sure to come back. thanks for sharing. and also This article gives the light in which we can observe the reality. this is very nice one and gives indepth information. thanks for this nice articlecustom wig pillow boxes

    ReplyDelete
  20. Great article! I enjoyed this movie and I thought the fight scenes are some of the best I’ve saw. I never thought this would be as good but I was wrong. I just watched it using my DISH online feature where I get thousands of movies I can watch and thought I would give this third movie a trcustom burger boxes

    ReplyDelete
  21. StickerZone is the fastest and easiest way to buy custom sticker printing. Order in 60 seconds and we’ll turn your designs and illustrations into custom stickers UK, custom labels, window, magnets, buttons and packaging in days. We offer free online proofs, free worldwide shipping and super fast turnaround. We don’t just custom stickers printing. StickerZone provide a wide variety of custom signage for all business types.
    Custom Sticker Printing

    ReplyDelete
  22. Present your products in the best quality custom printed boxes. Custom boxes make it easy to design and create beautiful custom printed boxes UK. Are you looking for Buy Packaging Boxes with Custom Packaging Boxes at wholesale prices? We offer a huge variety of custom packaging boxes at your doorstep with free shipping.
    Custom Boxes

    ReplyDelete